• Hi Guest: Welcome to TRIBE, the online home of TRIBE MAGAZINE. If you'd like to post here, or reply to existing posts on TRIBE, you first have to register. Join us!

Vista - language setting changes on its own...


TRIBE Member
Ok so I googled this but Im getting a sea of hits on standard, non-problem oriented stuff on language settings.

My brother and my friend both have the same issue as me: I was an idiot and selected "Canada Multilingual standard" on my most recent reformat, even though Vista was constantly reverting back to it in my previous install.

Issue is that the system keeps reverting back to the Canada standard, which f*cks up often used keys like "?" and "\" and even quotation marks and makes them french accented characters.

I actually got the alt-key shortcuts down so I dont need to keep the system on that setting and I keep hitting the little keyboard and selecting "US".

It never fails to revert back - on its own - to Canada. ITs super annoying. Is there a way to prevent this short of uninstalling the language standard?

The Watcher

TRIBE Member
Do you have the language bar on your start bar? it's on the systray by the time on the right on a default windows install (vista and xp)... usually just resembles a few letters in a button. Typically it says "EN" on a normal install and means english.

I've noticed that that button is real easy to accidentally click on and it may automatically go back to default. Try right clicking on it, go to properties and in one of the buttons you can remove the language button from the start bar.


TRIBE Member
Ya - I am DEFINITELY not accidentally clicking it.

Happened just now and it was fine before going upstairs - after dinner it was back on multilingual standard.

and its not in the systray but on the taskbar just to the left there - in my version (x64) its a little keyboard but I seen the En in my XP install.

Ièd remove it (SEEE !!! HAPPENED AGAIN!) but then it would be more of a pain to re-select ÈUSÈ again.


TRIBE Member
Possibly a keyboard stuck key issue or accidental hotkey issue? We do all our systems as Canadian English and never see this... once in a while, if I RDP into a euro system, I might get accidentally defaulted to german or other such language but there's always a cause.


TRIBE Member
Try this hastily googled suggestion

1. Open the Vista Control Panel.
2. Switch to Classic View and open Regional and Language Options.
3. Open the Keybaords and Languages tab.
4. Click “Change Keyboards”.

This is a list of all the languages you can toggle through using CTRL+SHIFT. US is probably the first in the list, followed by French or Spanish.

1. Delete all the languages, except for US (& canada multi if you REALLY need it).
2. Click OK, and OK again.

This guy's problem sounds similar if the above doesn't help.
Subscribe to Cannabis Goldsmith, wherever you get your podcasts

Aerius Zension

TRIBE Member
I get the exact same bloody problem and am not interested in restarting my computer each time it happens. Let me know if this works.