• Hi Guest: Welcome to TRIBE, the online home of TRIBE MAGAZINE. If you'd like to post here, or reply to existing posts on TRIBE, you first have to register. Join us!

Geek Thread:Trashed partition table? Can't boot/mount.

finary

TRIBE Promoter
I have a dual boot Windows XP - FreeBSD system with two hard drives. I wanted to take the BSD hard drive out and replace it with a fresh one to install BSD on to do some testing... once I was done with the testing I put the original BSD disk back in, so everything was back to normal.

I turned on the PC, and was now unable to boot to FreeBSD. (FreeBSD = primary slave)

There is also a Windows partition on the primary slave used for storage, which usually showed up as drive C: in Windows. Now it only recognizes the volume name, it wont mount it. (Volume name = PULSE)

I'm not sure exactly what the problem is here, or how it happened since all I did was swap the HDD out then put it back in... I'm guessing I may have screwed the partition table as I'm not able to see the mountpoints while using a FreeBSD fixit disk.

I've searched on the web and haven't had too much luck, theres alot of important data on the FreeBSD partition so I don't want to take any changes...

Any ideas?

Here's a screenshot from disk management...



/finary
 

oddmyth

TRIBE Member
What boot loader were you using? And if it was BSD boot loader, what was the name of it (ie. LILO, etc.)? Also, was the BSD system partitioned into seperate volumes, or were there separate partitions for system and user files?

odbx
 

finary

TRIBE Promoter
I was using the "FreeBSD Boot Loader"

The BSD system looked like this:

Disk status:
Filesystem 1K-blocks Used Avail Capacity Mounted on
/dev/ad0s2a 99183 61147 30102 67% /
/dev/ad0s2e 14756088 6031667 7543934 44% /usr
/dev/ad0s2f 99817 21810 70022 24% /var
procfs 4 4 0 100% /proc

(that is from the actual weekly mail-out)
 

finary

TRIBE Promoter
i just noticed something...
in windows it says that PULSE is 8GB and FreeBSD is 11GB

thats not possible since if you look at the freebsd filesystem, it is at least 15GB

it looks like the partition information is incorrect, and thats why neither windows nor BSD can see their own filesystems correctly... ?

hmm... ideas?
 
tribe magazine legacy photo exhibit

CLUSTER

TRIBE Member
remind me later, but when I get home there is a forum im a part of and these guys know their shit in and out.


Zigg'
 

~atp~

TRIBE Member
When you installed your test BSD, I'm guessing (given your symptoms) that you overwrote the mbr.

When you boot up your box now, is the boot loader still there? If it isn't, I'm about 95% certain that you overwrote your old mbr, in which case, to fix it, the easiest solution is to create a boot disk for BSD and manually go about reconfiguring the boot loader.
 

finary

TRIBE Promoter
That's impossible, the drive with the boot loader and freebsd was sitting on my desk while i installed the test bsd...

I simply plopped it back in, and the boot loader came up as usual, but I was unable to boot to FreeBSD. When I selected "FreeBSD" it loaded WindowsXP off the second drive instead. When I switched and chose the other option, it simply said "press any key to reboot" which is the message I would get if I tried to boot solely off the WINXP drive, since it was not bootable.

I think it's more than the MBR, since I still get the boot loader prompt.. because the partitions are there, but they are sized incorrectly. PULSE should be 3.42 GB and the remainder of the 20GB total should be FreeBSD, but you can see disk management is showing PULSE as 8GB and FreeBSD as 11...
 
tribe magazine legacy photo exhibit
Top